What are the minimum system requirements for the PostwireOutlook Plugin?

The PostwireOutlook Plugin minimum system requirements are:

  • Windows XP, Vista or 7
  • Processor: Dual Core 1.5GHz or higher
  • Ram: 2GB
  • Microsoft Office 2007 and Higher
  • Microsoft Word
Have more questions? Submit a request

Comments

  • Avatar
    Jeff Fichter

    Does the Outlook plug in work with Office 365?

Powered by Zendesk